Workstation Environment

The workstations and laptops are taken care by the Helpdesk. If you have any problems, please contact Helpdesk, and they will either solve your problem or route your message to the relevant experts. If you know for sure that your problem is better handled by the IT staff of the Department, you can also contact to the IT person of your Division, or the departmental IT staff mail list fyl-helpit (at) helsinki.fi.

Scientific Computing

Workstation environment for scientific computing is based on the linux distribution of University of Helsinki, Cubbli. Current version of Cubbli is based on Ubuntu 14.04 LTS.

The Department has an own software repository, which delivers few important packages missing from the official Ubuntu 14.04 and from Cubbli. The aim is to always have packages for the newest Ubuntu LTS release. If you have any urgent need for software which is not included in the distribution, please contact to the IT Staff of the department via email fyl-helpit (at) helsinki.fi.

Earlier we had packages for both 32-bit x86 and 64-bit x86_64 versions of Ubuntu. Starting at 12.04 repository, we now intend to only have 64-bit packages. If you feel that 32-bit packages are still needed, please let us know. We will not package them before somebody asks. According to Phoronix performance tests, one should run 64-bit linux whenever possible.

The repository is visible to the outside world also, so if anybody needs to use these packages at home, it suffices to have the lines:

# Repository of Department of Physics, University of Helsinki
deb http://www.physics.helsinki.fi/fylrepo/ubuntu xenial physics-main physics-universe
deb-src http://www.physics.helsinki.fi/fylrepo/ubuntu xenial physics-main physics-universe

added to the apt configuration file, e.g. /etc/apt/sources.list and to fetch the repository key with command:

wget -q http://docs.physics.helsinki.fi/repokey2016.asc -O- | sudo apt-key add -

The whole bunch of the departmental software with free or mostly free licenses can be installed via the dependency package physics-nonfree. Just apt-get install it, and it will fetch in all the rest of the software.

Of course, one should only add the repository if one trusts the administrators of the department. Whenever there are any problems in the software packages of the repository, please contact to fyl-helpit (at) helsinki.fi.